Issue affecting logging in

Incident Report for University of Essex IT

Resolved

This issue is now resolved. Thank you for your patience.

If you have any further issues, please contact the IT Helpdesk.
Posted Nov 26, 2025 - 10:02 GMT

Update

We have identified the issue and a change has been made which should see a reduction in these issues. Further updates to be provided.
Posted Nov 25, 2025 - 12:42 GMT

Investigating

We’re currently investigating an issue where some people are being asked for multi-factor authentication when signing in to certain services.

As a workaround, please try logging in using a private/incognito browser window.

Windows: Press CTRL + SHIFT + N
Mac: Press Command + Shift + N

Thank you for your patience while we work to resolve this.
Posted Nov 25, 2025 - 09:35 GMT
This incident affected: Other services.