Issues affecting essex.ac.uk and directories
Incident Report for University of Essex IT
Resolved
This issue is now resolved. Thank you for your patience.

If you have any further issues, please contact the IT Helpdesk.
Posted Mar 14, 2024 - 11:27 GMT
Monitoring
We have fixed the issue and we are monitoring the situation.
Posted Mar 14, 2024 - 10:36 GMT
Investigating
We're aware of an issue affecting our website and staff & student directories and are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Mar 14, 2024 - 09:23 GMT
This incident affected: University website.