Issue affecting Outlook & Calendars
Incident Report for University of Essex IT
Resolved
This issue is now resolved. Thank you for your patience.

If you have any further issues, please contact the IT Helpdesk.
Posted Nov 26, 2024 - 11:54 GMT
Monitoring
Microsoft have resolved the issues and we are monitoring to ensure that everything is working as expected.
Posted Nov 26, 2024 - 08:22 GMT
Update
Microsoft are continuing to investigate and implement a fix ASAP., however issues are still ongoing across multiple Microsoft 365 services.
Posted Nov 25, 2024 - 11:18 GMT
Investigating
We're aware of an issue affecting our Outlook and Calendars causing slow response times and failures with calendar entries. This is currently a global issue with Microsoft services currently being investigated.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Nov 25, 2024 - 09:53 GMT
This incident affected: Email.