To contact the Commercial Applications team, core users will be updated with a contact route. Alternatively, please email caquery@essex.ac.uk and this inbox will be monitored.
Alternatively, you can email develop@essex.ac.uk and one of the team will get back to you.
Apologies for any convenience at this time.
Posted Aug 04, 2025 - 09:24 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2025 - 14:00 BST
Scheduled
The Service Desk and Organisation Development customer portal will be unavailable between Friday 1st August 2pm - Monday 4th August 8am due to an upgrade.
The following teams will be affected, and may take longer to respond to incoming queries:
- IT Helpdesk - Commercial Applications - Organisational Development
Please submit a support ticket via email to it.helpdesk@essex.ac.uk where your ticket will automatically created when the Customer Portal is back online.
Alternative methods of contacting the IT Helpdesk during during office hours:
To contact the Commercial Applications team, core users will be updated with a contact route. Alternatively, please email caquery@essex.ac.uk and this inbox will be monitored.