Issue affecting Student Forms, Admissions Forms, and Travel Insurance Forms

Incident Report for University of Essex IT

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 17:09 GMT

Investigating

We're aware of an issue affecting our forms.essex.ac.uk service - which serves ESF student forms, Admissions forms, and travel insurance request forms - and are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Feb 05, 2025 - 14:44 GMT
This incident affected: Business applications (SharePoint).