Listen Again/Panopto is running slower than usual

Incident Report for University of Essex IT

Update

We are continuing to investigate this issue and are working with our suppliers to identify a cause.
Posted Nov 28, 2025 - 10:15 GMT

Investigating

We're experiencing performance issue with Listen Again and Panopto.

Our teams are working to restore normal performance and we'll post another update as soon as we know more.

We're sorry for the disruption.
Posted Nov 24, 2025 - 14:15 GMT
This incident affects: Learning tools (Listen Again).