Issue affecting LEAP

Incident Report for University of Essex IT

Investigating

We're aware of an issue affecting LEAP and are currently investigating. At the moment data within LEAP (including attendance data) is not currently up to date.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Feb 03, 2026 - 11:22 GMT
This incident affects: Learning tools (LEAP).