Issue affecting Department Timetables

Incident Report for University of Essex IT

Investigating

We're aware of an issue affecting searching Department Timetables (https://www1.essex.ac.uk/depttimetables/).

When using the 'Search By department' function users are receiving the following error:

"Sorry, no results found for your search criteria. The timetable may not have been published yet. Please check the timetable publication dates using the link below. If you believe there is an error with the timetable please email cto@essex.ac.uk for Colchester campus, and stuadmin@essex.ac.uk for Southend campus."

Other search functions on the site are available such as 'Search by module' and 'Search by academic'.

We are aware of the issue and are looking into resolve it as soon as possible, we are sorry for any inconvenience this may be causing you. One we have further information on the issue we will update you as soon as possible.
Posted Jul 17, 2026 - 12:19 BST
This incident affects: Learning tools (Timetables).