iTrent - People Manager - Essex Hours - HR organiser URL issue

Incident Report for University of Essex IT

Resolved

This incident has now been resolved.
Posted Mar 11, 2026 - 13:12 GMT

Identified

We have now identified that following the upgrade to HR Organiser yesterday, the following url will no longer be accessible. Going forward you will need to use https://hrorganiser.essex.ac.uk/ . Before attempting to connect to this new address, please ensure that you clear your cache, following these instructions https://support.google.com/google-ads/answer/32050?hl=en-GB&co=GENIE.Platform%3DDesktop
Posted Mar 10, 2026 - 13:39 GMT

Investigating

Following the upgrade to iTrent/People Manager/Essex Hours/HR Organiser, we are aware that the HR Organiser URL, that some users have saved in their favourites, does not currently work. We are currently investigating this and will advise in due course, however in the meantime you can access HR Organiser using the URL published on the universities web pages - https://hrorganiser.essex.ac.uk/tlive_lss/

We are sorry for any inconvenience caused and hope to resolve the issue as soon as possible.
Posted Mar 10, 2026 - 11:30 GMT
This incident affected: Business applications (HR Organiser, People Manager).