Issue affecting printing

Incident Report for University of Essex IT

Investigating

We're aware of an issue affecting our managed print service and are currently investigating.

Mobile printing is taking longer than usual and some MFDs may not release jobs. A restart of the MFD might fix this if you need to print but it may take longer than usual for it to be back online and ready to use.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Jul 23, 2026 - 11:59 BST
This incident affects: Printing.