Issue affecting websites and online forms for staff and students

Incident Report for University of Essex IT

Resolved

This issue has been resolved.
Posted Oct 21, 2025 - 10:26 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2025 - 10:06 BST

Update

We are continuing to investigate this issue.
Posted Oct 15, 2025 - 11:03 BST

Update

We are continuing to investigate this issue. Impact is more widespread than initially assessed - including the University website and MyEssex.
Posted Oct 15, 2025 - 11:01 BST

Investigating

We're aware of several issues affecting our EDRM websites (ESF, EAF, AOS, ECF etc) and online forms for staff and students (known as Collagen Forms) and are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Oct 14, 2025 - 15:01 BST
This incident affected: Business applications (ESIS, SharePoint), Learning tools (Timetables), and University website, Other services.