Issue affecting SharePoint Online and EDRM website services

Incident Report for University of Essex IT

Monitoring

Microsoft 365 is reporting a significant service degradation which is impacting SharePoint Online (SPO) and the EDRM websites reliant on SPO data. Users may experience delayed or failed file opening, stale content, and authentication issues. We are monitoring the situation awaiting updates from Microsoft.
Posted Sep 02, 2026 - 16:05 BST
This incident affects: Business applications (SharePoint).