Issue affecting the University of Essex Website

Incident Report for University of Essex IT

Investigating

We're aware of further issues reported this afternoon and are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted May 30, 2025 - 17:13 BST

Monitoring

We have made some changes to the service and have put mitigations in place. We are monitoring the situation.
Posted May 30, 2025 - 11:37 BST

Update

These issues are ongoing but being investigated by our web team. Apologies for any inconvenient this may cause.
Posted May 27, 2025 - 09:06 BST

Investigating

We're aware of an issue affecting our University of Essex website, preventing searches from returning results and are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted May 14, 2025 - 15:45 BST
This incident affects: University website.