Issue affecting iTrent, People Manager and HR Organiser
Incident Report for University of Essex IT
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 16:03 GMT
Monitoring
A change has been made and you should now be able to log in successfully. We are monitoring the situation however if you do experience any errors when logging in please email caquery@essex.ac.uk.
Posted Mar 15, 2024 - 11:46 GMT
Investigating
We're aware of an issue affecting iTrent, HR Organiser and People Manager meaning that some users are unable to login, or are getting error messages after logging in. We are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Mar 15, 2024 - 09:58 GMT
This incident affected: Business applications (HR Organiser, People Manager).