Availability of Office Online applications
Incident Report for University of Essex IT
Resolved
The issue was identified and resolved by Microsoft.
We have confirmed that services have been fully restored.
Posted Sep 24, 2024 - 14:44 BST
Investigating
We are currently investigating an issue that seems to be preventing access to Office Online applications (including Word and Excel).
Outlook online is still available. In the meantime, Office applications are available in our PC Labs and on the Library Laptop Loan devices.
Posted Sep 24, 2024 - 09:24 BST
This incident affected: Other services.