Issue affecting Parallels Applications

Incident Report for University of Essex IT

Resolved

This issue is now resolved. Thank you for your patience.

If you have any further issues, please contact the IT Helpdesk.
Posted Mar 21, 2025 - 09:44 GMT

Update

A partial fix has been implemented and we continue to work with our suppliers to resolve the wider issue.
Posted Mar 20, 2025 - 16:41 GMT

Investigating

We're aware of an issue affecting Parallels Apps via the Software Hub and are currently investigating.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.

In the meantime, the workaround is to use the Parallels Client on your device to create a new connection to parallels.essex.ac.uk, sign in with your work credentials and connect to applications via the client.
Posted Mar 20, 2025 - 11:37 GMT
This incident affected: Learning tools (Software Hub).