iTrent, People Manager and HR Organiser is now available for use. Apologies for the delay in bringing the service back up.
Posted Aug 11, 2025 - 21:14 BST
Update
Further to our earlier message relating to todays iTrent upgrade, unfortunately this is taking longer than expected, however we hope to release the system back for use later this evening. We apologise for any inconvenience this has caused.
Posted Aug 11, 2025 - 16:23 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 11, 2025 - 09:30 BST
Scheduled
The following services will be unavailable while we carry out essential maintenance:
- iTrent - People Manager - HR Organiser - Web Recruitment - External Examiner Nomination Portal
We're sorry for any inconvenience this may cause. We'll post an update as soon as the work is complete.
Posted Aug 04, 2025 - 17:14 BST
This scheduled maintenance affected: Business applications (HR Organiser, People Manager).