Issue affecting Mobile Print Service

Incident Report for University of Essex IT

Investigating

We're aware of an issue affecting our Mobile Print Service and are currently investigating.

As a workaround, Printing from a computer is still fully operational.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted Sep 16, 2026 - 10:52 BST
This incident affects: Printing.