Issue affecting Mobile Print Service

Incident Report for University of Essex IT

Resolved

This issue is now resolved, the UK outage was resolved by Canon early yesterday evening. Thank you for your patience.

If you have any further issues, please contact the IT Helpdesk.
Posted May 20, 2026 - 09:24 BST

Investigating

We're aware of an issue affecting our Mobile Print Service and are currently investigating.

As a workaround, Printing from an IT Lab computer is still fully operational.

Sorry for any inconvenience this may be causing you. We'll post another update as soon as we know more.
Posted May 19, 2026 - 14:06 BST
This incident affected: Printing.