Dynamics CRM is running slower than usual
Incident Report for University of Essex IT
Resolved
This issue is now resolved. Thank you for your patience.

If you have any further issues, please contact the IT Helpdesk.
Posted Jan 31, 2023 - 08:56 GMT
Monitoring
A fix has been applied and we are monitoring the situation.
Posted Jan 30, 2023 - 12:50 GMT
Investigating
We're experiencing performance issues with Dynamics CRM.

Our teams are working to restore normal performance and we'll post another update as soon as we know more.

We're sorry for the disruption.
Posted Jan 30, 2023 - 11:55 GMT
This incident affected: Business applications (CRM).